You are to set up Open Shortest Path First (OSPF) routing between all four routers in this network. All routers are to be assigned to area 0. The LAN addresses and subnet assignments for each network are provided in Table 1. You are required to create individual IP assignments for all devices in your network. Additionally, you are to configure the network according to the following specifications. Test your network carefully as you progress and verify that each task has been successfully completed.
Step 1. Prepare a list of IP addresses for each networking device in your network.
Step 2. You are to set the passwords for the console 0, vty 0 4, and enable secret to ciscopress
for each router.
Step 3. You are required to configure a Telnet connection to all routers.
Step 4. The VLAN1 IP address for SW1 should be set to 10.10.10.1.
Step 5. The default gateway address for SW1 should be set 10.10.10.250.
Step 6. The gateway of last resort on all routers should be set to R4’s Fa0/1 IP address.
Step 7. Create OSPF routing for the routers on the network. Use a process ID of 100 and use
area 0 for the backbone.
Step 8. Configure an access list that prevents any pings or Telnet connections to PC1 from any
host in the 10.10.30.0 or 10.10.40.0 network going to the 10.10.10.0 network.
Step 9. Be sure to save your configuration. You will be asked to demonstrate your network to
receive your
Solutions
```
PC1
C:\> ip address 10.10.10.15 255.255.255.0
C:\> gateway 10.10.10.250
PC2
C:\> ip address 10.10.20.25 255.255.255.0
C:\> gateway 10.10.20.250
PC3
C:\> ip address 10.10.30.35 255.255.255.0
C:\> gateway 10.10.30.250
PC4
C:\> ip address 10.10.40.45 255.255.255.0
C:\> gateway 10.10.40.250
SW1
SW1(config)# interface vlan 1
SW1(config-if)# ip add 10.10.10.1 255.255.255.0
SW1(config-if)# exit
SW1(config)# ip default-gateway 10.10.10.250
R1
R1(config)# enable secret ciscopress
R1(config)# line con 0
R1(config-line)# password ciscopress
R1(config-line)# login
R1(config)# line vty 0 4
R1(config-line)# password ciscopress
R1(config-line)# login
R1(config)# interface fa0/1
R1(config-if)# ip add 10.10.10.250 255.255.255.0
R1(config-if)# no shutdown
R1(config)# interface fa0/0
R1(config-if)# ip address 10.10.50.1 255.255.255.240
R1(config-if)# no shutdown
R1(config)# router ospf 100
R1(config-router)# network 10.10.50.0 0.0.0.15 area 0
R1(config-router)# network 10.10.10.0 0.0.0.255 area 0
R1(config)# ip route 0.0.0.0 0.0.0.0 10.10.40.250
R1(config)# access-list 101 deny icmp 10.10.30.0 0.0.0.255 10.10.10.0 0.0.0.255
R1(config)# access-list 101 deny icmp 10.10.40.0 0.0.0.255 10.10.10.0 0.0.0.255
R1(config)# access-list 101 deny tcp 10.10.30.0 0.0.0.255 10.10.10.0 0.0.0.255 eq telnet
R1(config)# access-list 101 deny tcp 10.10.40.0 0.0.0.255 10.10.10.0 0.0.0.255 eq telnet
R1(config)# access-list 101 permit ip any any
R1(config)# interface fa0/0
R1(config-if)# ip access-group 101 in
R2
R2(config)# enable secret ciscopress
R2(config)# line con 0
R2(config-line)# password ciscopress
R2(config-line)# login
R2(config)# line vty 0 4
R2(config-line)# password ciscopress
R2(config-line)# login
R2(config)# interface fa0/1
R2(config-if)# ip add 10.10.20.250 255.255.255.0
R2(config-if)# no shutdown
R2(config)# interface fa0/0
R2(config-if)# ip address 10.10.50.2 255.255.255.240
R2(config-if)# no shutdown
R2(config)# router ospf 100
R2(config-router)# network 10.10.50.0 0.0.0.15 area 0
R2(config-router)# network 10.10.20.0 0.0.0.255 area 0
R2(config)# ip route 0.0.0.0 0.0.0.0 10.10.40.250
R3
R3(config)# enable secret ciscopress
R3(config)# line con 0
R3(config-line)# password ciscopress
R3(config-line)# login
R3(config)# line vty 0 4
R3(config-line)# password ciscopress
R3(config-line)# login
R3(config)# interface fa0/1
R3(config-if)# ip add 10.10.30.250 255.255.255.0
R3(config-if)# no shutdown
R3(config)# interface fa0/0
R3(config-if)# ip address 10.10.50.3 255.255.255.240
R3(config-if)# no shutdown
R3(config)# router ospf 100
R3(config-router)# network 10.10.50.0 0.0.0.15 area 0
R3(config-router)# network 10.10.30.0 0.0.0.255 area 0
R3(config)# ip route 0.0.0.0 0.0.0.0 10.10.40.250
R4
R4(config)# enable secret ciscopress
R4(config)# line con 0
R4(config-line)# password ciscopress
R4(config-line)# login
R4(config)# line vty 0 4
R4(config-line)# password ciscopress
R4(config-line)# login
R4(config)# interface fa0/1
R4(config-if)# ip add 10.10.40.250 255.255.255.0
R4(config-if)# no shutdown
R4(config)# interface fa0/0
R4(config-if)# ip address 10.10.50.4 255.255.255.240
R4(config-if)# no shutdown
R4(config)# router ospf 100
R4(config-router)# network 10.10.50.0 0.0.0.15 area 0
R4(config-router)# network 10.10.40.0 0.0.0.255 area 0
R4(config)# ip route 0.0.0.0 0.0.0.0 10.10.40.250
Running config files
Switch 1
SW1# sh run
Building configuration...
Current configuration : 1310 bytes
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname SW1
!
no aaa new-model
system mtu routing 1500
ip subnet-zero
!
!
!
!
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
!
Vlan internal allocation policy ascending
!
!
interface FastEthernet0/1
!
interface FastEthernet0/2
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface Vlan1
ip address 10.10.10.1 255.255.255.0
no ip route-cache
!
ip default-gateway 10.10.10.250
ip http server
control-plane
!
!
line con 0
line vty 0 4
no login
line vty 5 15
no login
!
end
SW1#
Router 1
R1# sh run
Building configuration...
Current configuration : 800 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$KXED$S08d0zG3x3aiaeFjy7nCP
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.10.50.1 255.255.255.240
ip access-group 101 in
!
interface FastEthernet0/1
ip address 10.10.10.250 255.255.255.0
!
interface Serial0/0/0
no ip address
shutdown
!
interface Serial0/0/1
no ip address
shutdown
!
router ospf 100
network 10.10.10.0 0.0.0.255 area 0
network 10.10.50.0 0.0.0.15 area 0
log-adjacency-changes
!
ip route 0.0.0.0 0.0.0.0 10.10.40.250
!
!
ip http server
no ip http secure-server
!
!
!
access-list 101 deny icmp 10.10.30.0 0.0.0.255 10.10.10.0 0.0.0.255
access-list 101 deny icmp 10.10.40.0 0.0.0.255 10.10.10.0 0.0.0.255
access-list 101 deny tcp 10.10.30.0 0.0.0.255 10.10.10.0 0.0.0.255 eq telnet
access-list 101 deny tcp 10.10.40.0 0.0.0.255 10.10.10.0 0.0.0.255 eq telnet
access-list 101 permit ip any any
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
password ciscopress
login
line aux 0
login local ciscopress
line vty 0 4
password ciscopress
login
!
scheduler allocate 20000 1000
!
end
R1#
Router 2
R2# sh run
Building configuration...
Current configuration : 800 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$KXED$S08d0zG3x3aiaeFjy7nCP
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.10.50.2 255.255.255.240
!
interface FastEthernet0/1
ip address 10.10.20.250 255.255.255.0
!
interface Serial0/0/0
no ip address
shutdown
!
interface Serial0/0/1
no ip address
shutdown
!
router ospf 100
network 10.10.50.0 0.0.0.15 area 0
network 10.10.20.0 0.0.0.255 area 0
log-adjacency-changes
!
ip route 0.0.0.0 0.0.0.0 10.10.40.250
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
password ciscopress
login
line aux 0
login local ciscopress
line vty 0 4
password ciscopress
login
!
scheduler allocate 20000 1000
!
end
R2#
Router 3
R3# sh run
Building configuration...
Current configuration : 800 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$KXED$S08d0zG3x3aiaeFjy7nCP
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.10.50.3 255.255.255.240
!
interface FastEthernet0/1
address
shutdown
!
router ospf 100
network 10.10.30.0 0.0.0.255 area 0
network 10.10.50.0 0.0.0.15 area 0
log-adjacency-changes
!
ip route 0.0.0.0 0.0.0.0 10.10.40.250
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
password ciscopress
login
line aux 0
login local ciscopress
line vty 0 4
password ciscopress
login
!
scheduler allocate 20000 1000
!
end
R3#
Router 4
R4# sh run
Building configuration...
Current configuration : 800 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$KXED$S08d0zG3x3aiaeFjy7nCP
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 10.10.50.4 255.255.255.240
!
interface FastEthernet0/1
ip address 10.10.40.250 255.255.255.0
!
interface Serial0/0/0
no ip address
shutdown
!
interface Serial0/0/1
no ip address
shutdown
!
router ospf 100
network 10.10.40.0 0.0.0.255 area 0
network 10.10.50.0 0.0.0.15 area 0
log-adjacency-changes
!
ip route 0.0.0.0 0.0.0.0 10.10.40.250
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
password ciscopress
login
line aux 0
login local ciscopress
line vty 0 4
password ciscopress
no login
!
scheduler allocate 20000 1000
!
end
R4#
```
You might also like to view...
Match the following terms to their meanings:
I. run macro II. record macro III. edit macro IV. macro V. Macro-Enabled Document A. process of creating a macro B. process of playing back a macro C. a set of instructions that executes a task D. can use Visual Basic for Applications (VBA) E. contains VBA macro code
When working with a compiler, the ____ controls the conversion process of turning human-readable code into a machine-readable form.
A. browser B. programmer C. source program D. target program